Apptricity is currently unavailable
Incident Report for Tufts University
Resolved
The issue with the Apptricity (e-Expense) system has been resolved. If you are still experiencing any issues, please contact the TTS Sevice Desk.

TTS
Call: 617-627-3376
Email: it@tufts.edu
Posted Sep 19, 2018 - 09:34 EDT
Update
The Apptricity (e-Expense) system is currently still unavailable, and the Tech team is working to get the system up as soon as possible. We apologize for the inconvenience and will provide an update when the system is available.
Posted Sep 19, 2018 - 08:58 EDT
Update
Tufts Support Services (TSS) is currently working with our 3rd party vendor to resolve the issue with Apptricity. Next status update at 9AM.
Posted Sep 19, 2018 - 08:04 EDT
Investigating
TTS is aware that Apptricity website is currently unavailable. We are working to resolve the issue. Next status update at 8AM.
Posted Sep 19, 2018 - 07:05 EDT
This incident affected: Web Applications.