Inbound calls issue
Incident Report for Tufts University
Resolved
TTS service tests show issue is resolved. We will continue to monitor closely and follow-up with our vendor. Thank-you for your patience during this brief service disruption. Should you experience any further issues, please report to the Service Desk.
Posted 4 months ago. Dec 15, 2017 - 12:48 EST
Investigating
TTS is aware of reports of inbound phone calls not reaching Tufts. We are in contact with our vendor as there may be a broader problem. More information in 30-minutes.
Posted 4 months ago. Dec 15, 2017 - 12:39 EST
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.