Axium Dental System Issue.
Incident Report for Tufts University
Resolved
This incident has been resolved.
Posted Nov 06, 2017 - 12:00 EST
Update
As of 10:15 the Dental System is available.
Posted Nov 06, 2017 - 11:08 EST
Investigating
The Axium Dental System is experiencing intermittent login problems. TTS is actively working on the issue. We will post updates as they become available.

If you are experiencing issues please contact the TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted Nov 06, 2017 - 10:12 EST