Service disruption for exchange.tufts.edu
Incident Report for Tufts University
Resolved
This issue with exchange.tufts.edu has been resolved.
Posted Jun 12, 2017 - 13:03 EDT
Monitoring
Monitoring - With additional changes the situation has been stabilized.
TTS will continue monitoring throughout the weekend and will update again on Monday.
Posted Jun 09, 2017 - 21:31 EDT
Update
We continue to monitor the situation but issue seems to have improved.
If you have any issues with exchange.tufts.edu, please contact the Service Desk at 617-627-3376 or email at it@tufts.edu
Posted Jun 09, 2017 - 10:09 EDT
Update
Status: We continue to investigate.
The issue remains with our exchange.tufts.edu environment (apple mail, outlook, webmail and other clients). Should you be experiencing an issue, please try again. Office 365 is not experiencing any issues.
Posted Jun 09, 2017 - 09:05 EDT
Investigating
Issue began at: 6:45 AM on June 9th
Status: There are reports of intermittent issues with slowness and errors accessing exchange.tufts.edu and Tufts email via email clients.
TTS is currently investigating and will provide an update by 9:00 AM.

Users who use Office 365 and access their mail at outlook.com/tufts.edu or login.microsoftonline.com are not affected.
Posted Jun 09, 2017 - 08:18 EDT
This incident affected: Email.