EMS/ReserveTufts service disruption
Incident Report for Tufts University
Resolved
Resolved
Posted Oct 30, 2020 - 13:52 EDT
Investigating
Tufts University is aware of an issue with EMS/ReserveTufts and working with the vendor to resolve. Next update at noon or sooner, if resolved. Thanks for your patience while we work through this service disruption.
Posted Oct 30, 2020 - 10:51 EDT
This incident affected: Other.