eServe login issue
Incident Report for Tufts University
Resolved
eServe issue has been resolved. Thank you for your patience.
Posted 5 months ago. May 09, 2018 - 07:55 EDT
Investigating
TTS is aware of an issue impacting logon access to PeopleSoft HR and eServe. We are working to resolve the issue and will provide another update within the hour.
Posted 5 months ago. May 09, 2018 - 07:41 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.