South Cove Complex - Telephone Service
Incident Report for Tufts University
Resolved
This incident has been resolved.
Posted Oct 24, 2017 - 11:38 EDT
Update
South Cove Complex - Telephone Service should be restored.
If you are still experiencing phone issues please contact the TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Thanks,
TTS
Posted Oct 24, 2017 - 11:12 EDT
Monitoring
Due to a planned electrical maintenance, phone service for the entire South Cove complex (Stearns/Arnold/South) is currently down, once power has been restored, phone service, in turn, will be restored.

Thanks,
TTS
Posted Oct 24, 2017 - 09:37 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.