EmpowerTime service is down
Incident Report for Tufts University
Resolved
The EmpowerTime service is now operational. If there are any additional problems please contact the Tufts Service Desk at 617-627-3089 or it@tufts.edu.
Posted May 24, 2018 - 19:24 EDT
Update
TTS is still investigating the problem with EmpowerTime. Next update will be when the issue is resolved.
Posted May 24, 2018 - 15:46 EDT
Investigating
The EmpowerTime service is down. TTS is aware of the problem and is working on restoring it to service
Posted May 24, 2018 - 14:04 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.