Library websites service interruptions
Incident Report for Tufts University
Resolved
The library websites for Ginn, Hirsh and Tisch Libraries are now available. If you are still experiencing any issues, please contact the TTS Sevice Desk.

TTS
Call: 617-627-3376
Email: it@tufts.edu
Posted Jan 08, 2019 - 17:52 EST
Investigating
Some links on library websites for Ginn, Hirsh and Tisch Libraries are currently unavailable. The problem is under investigation.
Posted Jan 08, 2019 - 16:49 EST
This incident affected: Library Technologies.