Tufts Learning Center is currently unavailable
Incident Report for Tufts University
Resolved
The Tufts Learning Center is now available. If you are still experiencing an issue, please contact the Service Desk.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted Mar 18, 2019 - 11:47 EDT
Investigating
The Tufts Learning Center is currently unavailable due to a vendor service disruption affecting their platform. TTS staff are in contact with the vendor and following their service restoration efforts. The next update will be provided in 30 minutes.
Posted Mar 18, 2019 - 11:12 EDT
This incident affected: Learning Management Systems.