Walpole Clinic | Internet & WiFi Service Unavailable
Incident Report for Tufts University
Resolved
This incident has been resolved.
Posted Dec 24, 2018 - 22:14 EST
Investigating
TTS is currently aware of the network/WiFi connectivity issue impacting the Walpole Clinic, will advise shortly.

Thanks,

TTS HelpDesk
it@tufts.edu
Posted Dec 24, 2018 - 21:19 EST
This incident affected: Network Services.