Pearson Building Power Outage
Incident Report for Tufts University
Resolved
Power has been restored to Pearson. Wireless / wired services have been restored. If you are still experiencing any connectivity issues, please contact the TTS Sevice Desk.

TTS
Call: 617-627-3376
Email: it@tufts.edu
Posted 11 days ago. Sep 11, 2018 - 07:58 EDT
Update
6:30 AM Status Update
Parts of the Pearson Building remain with out commodity power. Facilities is still engage and trying to resolve the issue. Local wired / wireless services remain offline. The next status update will be at 8AM or when commodity power is restore.
Posted 11 days ago. Sep 11, 2018 - 06:40 EDT
Investigating
There is currently a disruption of electrical power affecting the Pearson Building that started around 7:13 PM this evening. University Facilities staff are currently onsite investigating the issue.
Posted 12 days ago. Sep 10, 2018 - 20:37 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.