Titan Network drive issue
Incident Report for Tufts University
Resolved
TTS has resolved the issue with applications/services that rely on TITAN. Please contact service desk if you are still experiencing any issue.

TTS Service desk
617-627-3376
it@tufts.edu
Posted 10 days ago. Oct 05, 2018 - 17:05 EDT
Investigating
TTS is aware of an issue with services that rely on TITAN and working to isolate and resolve. Issues include some applications/services such as AMP or departmental shares
Posted 10 days ago. Oct 05, 2018 - 13:21 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.