Medford/Somerville Campus Power Outage - 3/29
Incident Report for Tufts University
Resolved
Medford/Somerville Campus Power has been RESTORED.
Posted Mar 29, 2018 - 11:50 EDT
Monitoring
Medford/Somerville Campus is currently experiencing a Power Outage.

*Building NOT supported by a generator during the power outage will have NO network services (Wired and WiFi) at this time but will return shortly after the power has been restored. However, If the building is currently supported by a generator, all network services will remain available during the power outage.

Thanks,
TTS
Call: 617-627-3376
Email: it@tufts.edu
Posted Mar 29, 2018 - 11:12 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.