Issue with Box Services
Incident Report for Tufts University
Resolved
The issue with Box Services has been resolved by the vendor. If you are still experiencing any issues please contact the Service Desk.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted 3 months ago. Apr 04, 2019 - 06:09 EDT
Investigating
There is currently an issue with Box Services being reported by the vendor. Some aspects of the application is currently unavailable. The vendor is currently investigating the issue. Status updates for Box Services can be found here: https://status.box.com/.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted 3 months ago. Apr 04, 2019 - 05:52 EDT
This incident affected: Other.