Qualtrics - web-based survey tool is down
Incident Report for Tufts University
Resolved
Qualtrics should be functioning normally again.
Posted Aug 17, 2022 - 15:46 EDT
Update
Service issue appears to be on the vendor side as clients of Qualtrics are experiencing the same issue. We are working with the vendor to identify and resolve the issue.
Posted Aug 17, 2022 - 09:39 EDT
Investigating
We are aware that the login to the Qualtrics system is not working at this time. We are working to understand what is causing the service to be inaccessible and will provide an update once we understand the issue.
Posted Aug 17, 2022 - 09:24 EDT
This incident affected: Web Applications.