Boston telephone issues
Incident Report for Tufts University
Resolved
The telephone issues on the Boston campus have been resolved as of 12:30pm. Faulty hardware was replaced and we have confirmed that affected telephones are back in service. If you experience any issues going forward, please email it@tufts.edu or call 617-627-3376.

Thank you for your patience
Posted Jul 03, 2019 - 13:19 EDT
Investigating
TTS is aware of telephone issues on the Boston campus. Responsible personnel are on-site actively working to resolve the issue. Updates will be posted to status page. For additional information, please email it@tufts.edu or call 617-627-3376.

Thank you for your patience.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted Jul 03, 2019 - 11:04 EDT
This incident affected: Communication & Collaboration.