Apptricity currently unavailable
Incident Report for Tufts University
Resolved
The issue with Apptricity has been resolved. If you are still experiencing an issue please contact the Service Desk.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted 5 months ago. May 01, 2019 - 08:35 EDT
Investigating
TTS is aware of an issue accessing Apptricity. The vendor is currently investigating the issue. We currently do not have an ETA on when the service will be available. Next update at 9AM.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted 5 months ago. May 01, 2019 - 07:54 EDT
This incident affected: Financial Applications.