Inbound calling issues to Tufts phone numbers
Incident Report for Tufts University
Resolved
The inbound calling issue has been resolved.
Posted Aug 11, 2021 - 12:05 EDT
Monitoring
The inbound calling issue appears to be resolved.
We will continue to monitor.
Posted Aug 11, 2021 - 08:49 EDT
Investigating
TTS is aware of intermittent inbound calling issues.
We have a high priority ticket open with the vendor and continue to investigate.
Next update in 30 minutes.
Posted Aug 11, 2021 - 08:08 EDT
This incident affected: Other.