Microsoft authentication issue
Incident Report for Tufts University
Resolved
Microsoft has resolved their authentication issue and O365 services (email, calendar, storage) are available. Thank you for you patience while Microsoft worked to resolve the issue.
Posted Sep 28, 2020 - 20:28 EDT
Identified
Microsoft has identified and are reverting a recent change to the service which may be causing or contributing to impact.
Scope of impact: Any user may experience access problems for Microsoft 365 services.
Next update will be at 8:30 PM.

Please use the Tufts Status Page to monitor this issue: https://status.it.tufts.edu/
Posted Sep 28, 2020 - 19:23 EDT
Investigating
TTS is aware that Microsoft is experiencing issues with new Authentication since 5:30 which is impacting many O365 services.
We will continue to monitor and update.
Note: Please update your status page subscription to include an alternate email.
Posted Sep 28, 2020 - 18:23 EDT
This incident affected: Email.