Issues with Student Information System (SIS)
Incident Report for Tufts University
Resolved
The SIS issue has been resolved.
Posted about 1 month ago. Aug 18, 2017 - 15:27 EDT
Investigating
Tufts is currently experiencing intermittent issues with SIS. TTS is aware of the issue and is investigating. This page will be updated once we have more information.
Posted about 1 month ago. Aug 18, 2017 - 15:20 EDT
This incident affected: Student Technologies.