Webex service interruption
Incident Report for Tufts University
Resolved
The University Webex service has been restored and is available. If you are still experiencing any issues, please contact the Service Desk.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted Feb 27, 2019 - 08:05 EST
Identified
The University Webex service is currently unavailable.
We are working with the vendor to restore service.
Posted Feb 27, 2019 - 06:42 EST
This incident affected: Communication & Collaboration.