Inbound phone lines are currently experiencing issues.
Incident Report for Tufts University
Resolved
The issue has been resolved.

Any questions please contact the TTS Service Desk at (617) 627 - 3376 or email to it@tufts.edu.

Thank you for your patience.
Posted Oct 16, 2019 - 10:29 EDT
Investigating
Tufts Technology Services (TTS) is aware that the TTS Service Desk inbound phone lines are currently experiencing issues. Please contact the TTS Service Desk via email to it@tufts.edu while we work to resolve the issue. Provide a callback number as appropriate and an agent will contact you as soon as possible.

Thank you for your patience and understanding while we work to resolve this service interruption.
Posted Oct 16, 2019 - 09:22 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, and Research Technologies.