TuftsWork (Jira) Outage
Incident Report for Tufts University
Resolved
TuftsWorks (Jira) is back up and operational. Atlassian confirmed it was an outage affecting several clients and has not fixed it. Sorry for any inconvience.
Posted Aug 02, 2021 - 14:35 EDT
Update
We are continuing to investigate this issue.
Posted Aug 02, 2021 - 09:46 EDT
Investigating
TTS is aware of an issue with TuftsWork (Jira). We are working with the vendor (Atlassian) to determine and fix the issue.

We will post an update once we better understand the nature of the outage and how long it will be down.
Posted Aug 02, 2021 - 09:45 EDT
This incident affected: Other.