Intermittent Email Issue
Incident Report for Tufts University
Resolved
The issue with intermittent email has been resolved. Please contact the Service Desk with any questions or conerns.
Posted Nov 04, 2017 - 13:33 EDT
Investigating
TTS is aware on an intermittent email issue which is impacting one (1) mailbox server which stores email for approximately 400 users. We are working to resolve it promptly.

Any time sensitive questions/comments may be directed to the Service Desk: or (617) 627 - 3376
Posted Nov 04, 2017 - 12:36 EDT
This incident affected: Email.