Intermittent Connectivity Issue | Grafton Campus ONLY
Incident Report for Tufts University
Resolved
TTS has corrected the intermittent connectivity issues via the Grafton campus at 12:10pm, if you are still experiencing any issues, please reach out to the Tufts service desk.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted Jan 09, 2020 - 12:14 EST
Investigating
TSS is aware of intermittent connectivity issues on the Grafton Campus, we are currently working to resolve the issue.

TTS Service Desk
Call: 617-627-3376
Email: it@tufts.edu
Posted Jan 09, 2020 - 11:52 EST
This incident affected: Network Services.