Microsoft 365 and Exchange online delivery delays

Incident Report for Tufts University

Resolved

Microsoft has resolved the email delivery delays late yesterday (February 22). If you continue to have issues with email delivery, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Jan 23, 2026 - 07:24 EST

Monitoring

Microsoft has reported improved conditions and has seen significant reductions in the email delays experienced earlier. If you continue to have slowness sending or receiving email, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376
Posted Jan 22, 2026 - 19:52 EST

Update

Microsoft continues to work on correcting email delivery delays. Next update: 8:00 p.m.
Posted Jan 22, 2026 - 18:30 EST

Update

Microsoft continues to work on correcting email delivery delays. Next update: 6:30 p.m.
Posted Jan 22, 2026 - 17:05 EST

Investigating

TTS has been made aware of Microsoft 365 email delivery delays. Further information is available at: https://x.com/MSFT365Status/status/2014422298506285161

Next update: 5:00 pm
Posted Jan 22, 2026 - 15:52 EST
This incident affected: Email.