The Tufts Libraries catalog, JumboSearch, is currently unavailable
Incident Report for Tufts University
Resolved
The Tufts Libraries catalog, JumboSearch, is now available.
Posted Nov 02, 2019 - 12:47 EDT
Investigating
The Tufts Libraries catalog, JumboSearch, is currently unavailable. Our vendor is working on restoring the service as soon as possible. If you have any questions, please contact your library.
Posted Nov 02, 2019 - 10:15 EDT
This incident affected: Library Technologies.