Box issues

Incident Report for Tufts University

Resolved

Box has confirmed that the earlier issues have been resolved. If you continue to have trouble with Box, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Sep 04, 2025 - 16:02 EDT

Monitoring

Box has implemented a fix and is monitoring the results. Next update: 3:30 p.m.
Posted Sep 04, 2025 - 14:54 EDT

Investigating

TTS has been made aware of issues with Box, who says they are investigating an ongoing issue affecting Box. Users may experience errors or long load times using Box services. For more information, see https://status.box.com/

Next update: 3:00 p.m.
Posted Sep 04, 2025 - 14:22 EDT
This incident affected: Communication & Collaboration.