Issue in Tufts Summer Street data center
Incident Report for Tufts University
Resolved
All issues that were affecting our Tufts Summer St Data Center has been resolved. If you're still experiencing any issues please contact the Tufts Service Desk.

TTS Service Desk
617-627-3376
Posted Oct 17, 2020 - 11:33 EDT
Identified
The problem has been isolated and service is being restored.
If you continue to have issues after 9:15 AM please contact the service desk.
You can contact the TTS service desk by emailing it@tufts.edu or calling 617-627-3376
Posted Oct 17, 2020 - 08:59 EDT
Investigating
TTS is aware of an issue affecting our Tufts Summer St Datacenter. We are actively investigating and more information will be provided shortly at 9am.
Posted Oct 17, 2020 - 08:15 EDT
This incident affected: Other.