Microsoft licensing for students issue
Incident Report for Tufts University
Resolved
The Microsoft license issues that were reported earlier have been resolved. If you are still experiencing problems with Microsoft applications, including email, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Jan 13, 2025 - 14:53 EST
Investigating
Tufts Technology Services has been made aware of issues with Microsoft licensing for students. This may manifest in students not being able to use Microsoft applications, including email. Next update: 3:00
Posted Jan 13, 2025 - 13:37 EST
This incident affected: Email and Communication & Collaboration.