Echo360 lecture recording service issue
Incident Report for Tufts University
Resolved
Service to the Echo360 website has been restored. If you are still experiencing issues using Echo360 or viewing recordings, please contact the Service Desk.
Posted 2 months ago. Sep 14, 2018 - 15:46 EDT
Investigating
"The Echo360 lecture recording service is having a service disruption (https://status.echo360.com/). It's been going on for about 45 minutes. At the moment, users will find it difficult or impossible to view recordings. Users who use the website interface to schedule or start lectures will find it inaccessible. The vendor is investigating the issue."
Posted 2 months ago. Sep 14, 2018 - 10:59 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.