Office365 Email experiencing service degradation
Incident Report for Tufts University
Resolved
The vendor reports that the Office365 email service is full restored. Please contact the TTS service desk if you encounter additional issues.
Posted Jul 19, 2019 - 13:55 EDT
Identified
Tufts Technology Services (TTS) is aware that there is degraded performance with Office365 email.
We will continue to monitor the service and will provide updates as new information becomes available.
You can monitor the status here: https://downdetector.com/status/office-365
Posted Jul 19, 2019 - 12:04 EDT
This incident affected: Email.