Box Critical Issues with Accessing Content, Logins, Public API, Uploads, and Downloads
Incident Report for Tufts University
Resolved
The issue with Box has been resolved. If you are still experiencing any issues please reach out to the TTS Service Desk (617-627-3376).
Posted Apr 01, 2021 - 11:16 EDT
Update
Update from Box:

We have observed a full recovery and we will continue to monitor this issue.
Posted Apr 01, 2021 - 09:01 EDT
Monitoring
Latest update from Box:

We are seeing initial signs of recovery. Users should notice less of an impact at this time, as we continue to monitor and remediate this issue
Posted Apr 01, 2021 - 07:59 EDT
Investigating
TTS is aware of a critical issue with Box. Below is a status from Box:

We are currently investigating an ongoing issue affecting latency in Box.com, Box Drive, Box Notes, Box Sync and Box API. Logging in and accessing content may also be impacted. We will provide more information as soon as it is available.

More information is available on Box status page:

https://status.box.com/
Posted Apr 01, 2021 - 06:18 EDT
This incident affected: Communication & Collaboration.