Zoom outage

Incident Report for Tufts University

Resolved

Zoom has reported resolution of the issue. If you continue to have difficulty with any Zoom meetings, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Apr 16, 2025 - 19:51 EDT

Monitoring

Zoom has reported resolution of the issue. If you continue to have difficulty with any Zoom meetings, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Apr 16, 2025 - 17:00 EDT

Investigating

Tufts Technology Services has been made aware of vendor-related problems with Zoom. We suggest you use Microsoft Teams for meetings as a temporary alternative.

Next update: 5:00 p.m.
Posted Apr 16, 2025 - 15:33 EDT
This incident affected: Communication & Collaboration.