Canvas outage

Incident Report for Tufts University

Resolved

Canvas is operational. If you continue to have trouble accessing Canvas, please email canvas@tufts.edu.
Posted May 08, 2026 - 14:35 EDT

Monitoring

Canvas is operational again.

If you continue to have issues with Canvas, please email canvas@tufts.edu
Posted May 08, 2026 - 08:23 EDT

Update

Canvas (the student LMS) remains unavailable due to a widespread vendor issue. TTS recommends not logging in to Canvas until further notice. For further information, see:
https://tufts.app.box.com/s/y1tgoptdp2ncsjtedn0bhw6agzvy39p4
Posted May 07, 2026 - 19:51 EDT

Investigating

TTS has been impacted by the nationwide Canvas outage (the student LMS). Next update: 8:00

For more up-to-date information, see the vendor's webpage: https://status.instructure.com/
Posted May 07, 2026 - 17:03 EDT
This incident affected: Learning Management Systems.