This maintenance has been cancelled will be rescheduled for a later date.
Posted Aug 08, 2025 - 14:57 EDT
Scheduled
TTS will transition to a new firewall on Saturday, August 9, starting at 6:00 a.m.
A network outage of up to 30 minutes is expected during the switch from the existing firewall to the new system. Access to Tufts services and applications may be temporarily unavailable during this period.
Applications and services that rely on the firewall may experience brief interruptions during the changeover. While significant issues are not expected after maintenance is complete, some applications and services may need to be restarted or require additional steps to resume normal operation which could take some time to address.
Posted Jul 31, 2025 - 11:10 EDT
This scheduled maintenance affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, and Research Technologies.