Egencia Travel Website Currently Unavailable

Incident Report for Tufts University

Resolved

The Egencia website, which Tufts uses for booking university travel, is back online.

Thank you for your patience while we resolved the issue.
Posted Feb 23, 2026 - 11:54 EST

Identified

The Egencia website, which Tufts uses for booking university travel, is still unavailable for Tufts users.

We are have isolated the issue and are working through a resolution. We will provide an update once a solution is in place.

In the meantime, you can still book travel by contacting Egencia directly by phone at (312) 741-6713.
Posted Feb 23, 2026 - 11:05 EST

Investigating

The Egencia website, which Tufts uses for booking university travel, is currently unavailable for Tufts users.

We are working to understand the cause and will provide updates as soon as more information becomes available. We do not yet have an estimated time for resolution.

In the meantime, you can still book travel by contacting Egencia directly by phone at (312) 741-6713.
Posted Feb 19, 2026 - 11:09 EST
This incident affected: Web Applications and Other.