Duo authentication services unavailable
Incident Report for Tufts University
Resolved
The vendor has resolved the issue with Duo and the authentication services are back online. Thank you for your patience. If you continue to have issues logging in please reach to the service desk at it@tufts.edu or 617-627-3376
Posted Oct 16, 2018 - 11:51 EDT
Investigating
We have identified an issue with logins to some of our Core Authentication service that use DUO. The vendor is working to correct the issue. We will provide an update in 15 minutes.
Link to the vendor's status page: https://status.duo.com/
Posted Oct 16, 2018 - 11:35 EDT
This incident affected: Authentication Services.