Digital Signage
Incident Report for Tufts University
Resolved
TTS has worked with the vendor to resolve the digital signage issues. If you continue to have difficulties with digital signage in your area, please contact the TTS Service Desk at 617-627-3376.
Posted Apr 04, 2023 - 08:33 EDT
Monitoring
Many of the digital signage players are back online.  Please contact the TTS Service Desk at 617-627-3376 for issues with any particular player. TTS will be reaching out directly to Digital Signage Users with additional information.
Posted Mar 24, 2023 - 15:36 EDT
Investigating
An issue at our Digital Signage vendor has caused a number of displays across the campus to stop working. TTS is in contact with the vendor, and will be reaching out to individual clients with additional information and updated instructions on accessing their systems. In the meantime, please contact the Service Desk at 617-627-3376 if you would like a sign to be manually turned off as we work toward resolution.
Posted Mar 24, 2023 - 13:33 EDT
This incident affected: Other.