Box issues
Incident Report for Tufts University
Resolved
TTS has been informed that the Box issues have been resolved. If you continue to have difficulties, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Dec 15, 2023 - 16:02 EST
Monitoring
Box has identified the issue and implemented steps to fix. If you continue to see difficulties with Box, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Dec 15, 2023 - 12:56 EST
Update
Access to Box via the web and via Box Drive continues to be unavailable, per the vendor. The vendor has posted an update on their status page: https://status.box.com/

Next update: 1:30 p.m.
Posted Dec 15, 2023 - 12:04 EST
Update
We continue to see issues with Box (both via the web and Box Drive). The vendor has posted an update on their status page: https://status.box.com/

Next update: 12:00 p.m.
Posted Dec 15, 2023 - 10:30 EST
Investigating
TTS has been made aware of issues with Box (both via the web and Box Drive). The vendor has posted an update on their status page https://status.box.com/

Next update: 10:15 a.m.
Posted Dec 15, 2023 - 09:24 EST
This incident affected: Communication & Collaboration.