Box issues

Incident Report for Tufts University

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 19:24 EDT

Monitoring

Earlier issues with Box have been resolved. If you continue to have trouble with Box, particularly Box via the web, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Jun 17, 2026 - 17:03 EDT

Identified

TTS has been made aware of degraded performance with Box, particularly Box via the web. For more information see the Box status page at https://status.box.com/ Next update: 7:00
Posted Jun 17, 2026 - 16:15 EDT
This incident affected: Communication & Collaboration.