Software and Apps page on AccessTufts down
Incident Report for Tufts University
Resolved
The issue has been resolved and the Apps and Software Store on AccessTufts is up and running.
Posted Jan 04, 2024 - 14:07 EST
Investigating
TTS is aware that the Software and Apps Store on AccessTufts (access.tufts.edu/sofware) is currently unavailable. We are investigating the source of the issue and will notify the community once it is up and running again. Sorry for any inconvenience.
Posted Jan 04, 2024 - 13:01 EST
This incident affected: Web Applications.