Duo issues - phone calls, Microsoft applications

Incident Report for Tufts University

Resolved

The issues some individuals were seeing earlier with Duo have been resolved. If you continue to have repeated difficulties with Duo, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Feb 23, 2026 - 12:43 EST

Update

Duo continues to investigate the issues (using "phone" as a second factor, and authenticating to Microsoft applications). Next update: noon.
Posted Feb 23, 2026 - 11:03 EST

Investigating

TTS has been made aware of multiple issues with Duo. The first failure mode is with clients who use "phone" as a second factor. The second failure mode is when attempting to authenticate with Microsoft applications. Next update: 11:00
Posted Feb 23, 2026 - 10:16 EST
This incident affected: Authentication Services.