Century Link Internet Service Provider Outage
Incident Report for Tufts University
Resolved
This incident has been resolved. If you are still experiencing any issues please contact the service desk.
TTS Service Desk
(617) 627-3376
it@tufts.edu
Posted Aug 30, 2020 - 13:00 EDT
Monitoring
TTS is aware of an Internet Service Provider outage - century link - across North America.  It is impacting the availability of externally hosted services for users in some locations, including ServiceNow, Duo, etc.

Should you experience an issue, please try the VPN.  It may help in some instances.

We will continue to monitor and post as new information is available.
Posted Aug 30, 2020 - 10:11 EDT
This incident affected: Other.