Authentication issues with SIS and eServe

Incident Report for Tufts University

Resolved

Yesterday's vendor-related authentication issues with SIS, eServe, and Peoplesoft Finance have been resolved. If you continue to have issues, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Sep 09, 2026 - 06:54 EDT

Monitoring

The earlier vendor-related authentication issues affecting SIS, eServe, and Peoplesoft Finance have been resolved. If you continue to have trouble logging in to any of those sites, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Sep 08, 2026 - 18:55 EDT

Update

TTS continues to investigate the authentication issues affecting SIS, eServe, and Peoplesoft Finance. At the moment all indications point to this being a vendor issue. Next update: 8:00 pm.
Posted Sep 08, 2026 - 18:36 EDT

Update

TTS continues to investigate the authentication issues with SIS and eServe. Next update: 6:30 pm.
Posted Sep 08, 2026 - 17:01 EDT

Update

TTS continues to investigate the authentication errors with SIS and eServe. Next update: 5:00 pm.
Posted Sep 08, 2026 - 16:00 EDT

Investigating

TTS has been made aware of authentication issues with SIS and eServe. Next update: 4:00.
Posted Sep 08, 2026 - 15:25 EDT
This incident affected: Authentication Services.