Microsoft Outlook (Classic) issues

Incident Report for Tufts University

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 17:25 EDT

Monitoring

The earlier issues with Microsoft Outlook (Classic) have been resolved. If you continue to have difficulties using Classic Outlook, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Apr 29, 2026 - 12:35 EDT

Investigating

TTS has been made aware of issues that some people are having with Microsoft Outlook (Classic). A workaround is to use Outlook Web Access https://outlook.office.com/

Next update: 10:00
Posted Apr 29, 2026 - 09:02 EDT
This incident affected: Email.