SIS Web page is currently down and being worked on.
Incident Report for Tufts University
Resolved
The SIS web page is back up.
Posted 11 days ago. Oct 04, 2018 - 16:46 EDT
Investigating
SIS website temporarily down. TTS is aware of the issue and currently working on the it.
Posted 11 days ago. Oct 04, 2018 - 16:22 EDT
This incident affected: Authentication Services, Student Technologies, Learning Management Systems, Library Technologies, Support Requests, Email, Clinical Services, Financial Applications, HR Applications, Communication & Collaboration, Web Applications, Network Services, Datacenter Services, Research Technologies, and Other.