axiUm (Dental) performance issues
Incident Report for Tufts University
Resolved
The performance issues with Dental Clinical application axiUm have been resolved. If you continue to have difficulties with axiUm, please contact the 24x7 IT Service Desk at it@tufts.edu or 617-627-3376.
Posted Oct 19, 2023 - 14:54 EDT
Investigating
Tufts Technology Services has been made aware of performance issues with the Dental Clinical application axiUm. Next update: 2:30 p.m.
Posted Oct 19, 2023 - 13:46 EDT
This incident affected: Clinical Services.