Microsoft Teams
Incident Report for Tufts University
Resolved
Microsoft has reported that the issues with its Teams service have been resolved. If you continue to have difficulties with Teams, please contact the 24x7 IT Service Desk at 617-627-3376 or it@tufts.edu.
Posted Jan 27, 2024 - 07:15 EST
Update
Microsoft reports a reduction in the impact but issues with Teams remain. For more information, see the Microsoft status page: https://portal.office.com/servicestatus
Posted Jan 26, 2024 - 17:29 EST
Update
Issues with Microsoft Teams continues. The vendor continues to attempt to restore services. Further information at https://portal.office.com/servicestatus
Next update at 5:30
Posted Jan 26, 2024 - 16:28 EST
Investigating
TTS has been made aware of issues with Microsoft Teams. For more information, see the Microsoft status page: https://portal.office.com/servicestatus

Next update: 4:00 or sooner.
Posted Jan 26, 2024 - 14:31 EST
This incident affected: Communication & Collaboration.